Boat Maintenance: Nav Light Problem
(Hatchet Creek Specific)
0 messages
Updated
Lakes Online Forum
83,755 messages
Updated 7/18/2024 8:20:58 PM
Lakes Online Forum
5,198 messages
Updated 6/19/2024 3:45:44 AM
(Hatchet Creek Specific)
0 messages
Updated
Lakes Online Forum
4,171 messages
Updated 6/27/2024 7:05:46 AM
Lakes Online Forum
4,261 messages
Updated 5/28/2024 6:31:10 AM
Lakes Online Forum
2,979 messages
Updated 6/26/2024 5:03:03 AM
Lakes Online Forum
98 messages
Updated 4/15/2024 1:00:58 AM
Hatchet Creek Photo Gallery





    
Welcome, Guest Select View Mode: [ classic | beta | recent ]
Name:   ninaholm The author of this post is registered as a member - Email Member
Subject:   Nav Light Problem
Date:   2/11/2020 6:44:30 AM

I'm having an issue with my Navigation lights. All of a sudden they have stopped working, both fore and aft. Here is what I have learned so far:
1. Stern white light gets 12V of power all the way to the socket for the light bulb on top of the removable pole.I cleaned the connections on the pole, the socket, and the wiring below.
2. Bow lights get no voltage at all. It is a one light two color lamp there. I have cleaned the connections and re-crimped and still no voltage at all, even to a brand new light.
3. Switch that goes from Nav to off to Anchor seems to be working. Voltage is switched on and off to both locations as is appropriate.

Other messages in this thread:View Entire Thread
Nav Light Problem - MrHodja - 8/15/2019 8:59:44 PM
     Nav Light Problem - GoneFishin - 8/17/2019 5:07:26 PM
          Nav Light Problem - Shortbus - 8/18/2019 10:25:43 PM
               Nav Light Problem - MrHodja - 8/19/2019 10:27:03 AM
                    Nav Light Problem - GoneFishin - 9/1/2019 10:17:51 PM
     Nav Light Problem - ninaholm - 2/11/2020 6:44:30 AM
          Nav Light Problem - krtracker - 5/29/2020 5:40:11 PM





About Us
Contact Us
Site Map
Search Site
Advertise With Us
   
Hatchet.DiscoverRivers.com
THE HATCHET CREEK WEBSITE

Copyright 2024, Discover Rivers
Privacy    |    Legal